My 1972 Gen2 build

Discussion in 'Pre-1975 Build-Up/Project Threads' started by jetas, Jan 11, 2016.

  1. jetas

    jetas Grand Toyotaholic

    Joined:
    Mar 26, 2009
    Messages:
    4,541
    Likes Received:
    294
    Location:
    Oxnard, CA
    Truck:
    72.5 Hilux
    So on sunday during my 60 mile round trip to the park my gas gauge took a dump. I think it was the shitty Thai sending unit that failed me again. Not sure when il drop the tank but its going to have to happen again.
     
  2. jetas

    jetas Grand Toyotaholic

    Joined:
    Mar 26, 2009
    Messages:
    4,541
    Likes Received:
    294
    Location:
    Oxnard, CA
    Truck:
    72.5 Hilux
    Well ive had the tuck on jackstands all week, messed with the sending unit a bunch and ive gotten it to read within range but i hook it up to the gauge and when the sending unit is in the Full position the gauge only shows half, at Empty it shows empty. So its going back in tonight screw it.

    Il be ordering an aftermarket sendig unit along with the quad gauge from Speedhut. Il find a way to make it all work with the tank
     
  3. Hands_On_Henry

    Hands_On_Henry Member

    Joined:
    Dec 5, 2017
    Messages:
    65
    Likes Received:
    12
    Location:
    Michigan
    Truck:
    1985 22R/4spd
    Sounds like it will be much better once you get through the headaches. I hate dealing with gas tanks....
     
  4. jetas

    jetas Grand Toyotaholic

    Joined:
    Mar 26, 2009
    Messages:
    4,541
    Likes Received:
    294
    Location:
    Oxnard, CA
    Truck:
    72.5 Hilux
    Well another issue arose. Went to change the seal at the pinion, and now im in the middle of changing the pinion bearings. FML
     

Share This Page