jumping speedo

Discussion in 'Interior/Electronics' started by coy, Jan 23, 2020.

  1. coy

    coy Member

    Joined:
    Jan 22, 2020
    Messages:
    34
    Likes Received:
    17
    so when its cold, the speedo would randomly jump allover the place. i'd be going 5-10 mph but it'll jump wildly. when its warm, it would do it still, but not as much. what should I investigate first?

    I know its cable driven. i'm not sure if its the cluster that's having issues or the cable. I also noticed when its pegged past 120, the whole needle kinda moves in a circle.

    I did remove the cluster to change the bulbs to LED when I first got it, but it didn't have an issue till about the 6th time I drove it.
     
  2. Justin Danger

    Justin Danger Addict

    Joined:
    Aug 6, 2016
    Messages:
    640
    Likes Received:
    130
    Location:
    Bay Area Peninsula
    Truck:
    1986 Toyota Xtra cab SR5 Turbo 22rte
    Did you disconnect the cable from the cluster when you pulled it for the LED swap? I have taken mine out a few times (cable driven as well) and I have had really odd issues with my speedo if it was re-connected funny or off. The pin has to go in the hole, and has to go deep enough for the clip to click in.
     
  3. coy

    coy Member

    Joined:
    Jan 22, 2020
    Messages:
    34
    Likes Received:
    17
    yeah. I did. but ive driven it a few times after and all of a sudden it does this..?? I checked to see if it was plugged in all the way the first time it did it, and it seemed snug. I didn't unplug and plug it back in again. i'll do that again to try and re-seat it.
     
  4. jetas

    jetas Grand Toyotaholic

    Joined:
    Mar 26, 2009
    Messages:
    5,528
    Likes Received:
    566
    Location:
    Oxnard, CA
    Truck:
    72.5 Hilux
    Make sure its nice and greased up
     
  5. coy

    coy Member

    Joined:
    Jan 22, 2020
    Messages:
    34
    Likes Received:
    17
    I read that's what you do if its 'wiggling'. my issue is that I would go 10mph and the damn thing jumps all over the place!!
     
  6. RaceLab

    RaceLab Newbie

    Joined:
    Jun 8, 2020
    Messages:
    8
    Likes Received:
    1
    did you resolve the issue? i was thinking it would either be a binding speedo cable or a worn speedo driven gear where the speedo connects to the trans...
     

Share This Page