75 Hilux Hazards and Horn not working

Discussion in 'Maintenance/Repair' started by daruma, Jun 15, 2014.

  1. daruma

    daruma Member

    Joined:
    Sep 25, 2011
    Messages:
    57
    Likes Received:
    2
    Hey everyone,

    I have a 75 Hilux, and for some reason the horn and the hazards stopped working. The turn signals work, and the fuse for the turn signal is good. Where might my problem be?
     
  2. Maine88

    Maine88 Newbie

    Joined:
    Jul 18, 2020
    Messages:
    4
    Likes Received:
    0
    Location:
    Canada
    Truck:
    1975 2wd longbox pickup
    Hey I have the same issue with my 75
    Did you figure this out yet ?
     
  3. jetas

    jetas Grand Toyotaholic

    Joined:
    Mar 26, 2009
    Messages:
    5,401
    Likes Received:
    521
    Location:
    Oxnard, CA
    Truck:
    72.5 Hilux
    Clockspring is probably the issue. Pull the steering wheel and column covers and inspect it. Could just be corrosion, lots of bare metal contacts in there
     
  4. Maine88

    Maine88 Newbie

    Joined:
    Jul 18, 2020
    Messages:
    4
    Likes Received:
    0
    Location:
    Canada
    Truck:
    1975 2wd longbox pickup
    Hey thanks ,I had the wheel off to inspect few days ago everything seemed fine I’m going to go back and double check .. the truck didn’t have a horn at all when I got it so I got one from the junk yard but I’m not sure of the wiring because my engine bay is kinda of mess there’s a few plugs just hanging and not plugged in .. If I can’t figure it out I’ll take some pics and post
     
  5. Maine88

    Maine88 Newbie

    Joined:
    Jul 18, 2020
    Messages:
    4
    Likes Received:
    0
    Location:
    Canada
    Truck:
    1975 2wd longbox pickup
    So I’m trying to get the horn working I took one from a camery are these the wires for the horn? The two short ones that I have stripped?
    Also is there a fuse for the horn I can’t seem to find a fuse for it
     

    Attached Files:

Share This Page